DEADSOFTWARE

fpc 3.2 fixes and rpm spec.
[d2df-editor.git] / rpm / d2df-editor.spec
1 #
2 # Doom2D Forever spec file. It's a official build of editor for Linux.
3 # Maintainer: Dmitry Lyashuk <lyashuk.voxx@gmail.com>
4 #
5 # Copyright (C) Doom 2D: Forever Developers
6 #
7 # This program is free software: you can redistribute it and/or modify
8 # it under the terms of the GNU General Public License as published by
9 # the Free Software Foundation, version 3 of the License ONLY.
10 #
11 # This program is distributed in the hope that it will be useful,
12 # but WITHOUT ANY WARRANTY; without even the implied warranty of
13 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 # GNU General Public License for more details.
15 #
16 # You should have received a copy of the GNU General Public License
17 # along with this program. If not, see <http://www.gnu.org/licenses/>.
18 #
20 Name: d2dforever
21 Version: v0.667
22 Release: %mkrel 1
23 Summary: Doom-themed platformer with network play
24 Source0: doom2df-editor.png
25 Source1: doom2df_editor.desktop
26 URL: http://doom2d.org
28 BuildRequires: fpc lazarus
30 Group: Games/Arcade
31 License: GPLv3
32 Provides: d2df-editor
34 %description
35 Doom-themed platformer with network play, modern port of the 1996 Doom 2D by Prikol Software. Package contains main binary, headless binary and editor binary with icons and desktop files. Manual (man d2df) included.
37 %prep
39 # Editor sources.
40 cd ..
41 git clone http://repo.or.cz/d2df-editor.git
42 cd d2df-editor
43 mkdir bin
44 mkdir tmp
46 %build
47 cd d2df-editor/src/editor
49 # Editor bin.
50 export D2DF_BUILD_HASH="$(git rev-parse HEAD)"
51 lazbuild --bm=Debug Editor.lpi
53 %install
55 # Create directories.
56 install -dm755 %{buildroot}/{usr/{bin,share/pixmaps}}
57 install -dm755 %{buildroot}/usr/share/doom2df
59 # Installing files.
60 # Editor.
61 cd ../..
62 cd d2df-editor/bin
63 install -D -m755 editor %{buildroot}%{_bindir}/Editor
65 # Other.
66 install -D -m644 %{SOURCE1} %{buildroot}/usr/share/pixmaps/doom2df-editor.png
67 install -D -m644 %{SOURCE3} %{buildroot}/usr/share/applications/doom2df_editor.desktop
69 %clean
70 rm -Rf d2df-editor
71 rm -Rf %{buildroot}
73 %files
74 %defattr(0755,root,root)
76 # Binaries.
77 %{_bindir}/Editor
79 # Icons.
80 /usr/share/pixmaps/doom2df-editor.png
82 # Desktop files.
83 /usr/share/applications/doom2df_editor.desktop