DEADSOFTWARE

342ea25d360b11f5688084814159b965d319d21a
[d2df-sdl.git] / rpm / d2dforever.spec
1 #
2 # Doom2D Forever spec file. It's a official build of game for Linux.
3 # Maintainer: Dmitry Lyashuk <lyashuk.voxx@gmail.com>
4 #
5 # Copyright (C) Doom 2D: Forever Developers
6 #
7 # This program is free software: you can redistribute it and/or modify
8 # it under the terms of the GNU General Public License as published by
9 # the Free Software Foundation, version 3 of the License ONLY.
10 #
11 # This program is distributed in the hope that it will be useful,
12 # but WITHOUT ANY WARRANTY; without even the implied warranty of
13 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 # GNU General Public License for more details.
15 #
16 # You should have received a copy of the GNU General Public License
17 # along with this program. If not, see <http://www.gnu.org/licenses/>.
18 #
20 Name: d2dforever
21 Version: v0.667
22 Release: %mkrel 1
23 Summary: Doom-themed platformer with network play
24 Source0: doom2df.png
25 Source1: doom2df.desktop
26 Source2: d2df.1
27 URL: http://doom2d.org
29 BuildRequires: fpc libenet-devel libvorbis-devel libopus-devel libopusfile-devel libgme-devel libxmp-devel libopenal-devel libsdl2.0-devel
31 Group: Games/Arcade
32 License: GPLv3
33 Requires: libenet7 libsdl2.0_0 openal libvorbis0 libopus0 libopusfile0 libgme0 libxmp4
34 Provides: d2dforever
36 %description
37 Doom-themed platformer with network play, modern port of the 1996 Doom 2D by Prikol Software. Package contains main binary, headless binary and editor binary with icons and desktop files. Manual (man d2df) included.
39 %prep
41 # Game sources.
42 git clone http://repo.or.cz/d2df-sdl.git
43 cd d2df-sdl
44 mkdir bin
45 mkdir tmp
47 %build
48 cd d2df-sdl/src/game
50 # Main bin.
51 export D2DF_BUILD_HASH="$(git rev-parse HEAD)"
52 fpc -g -gl -FE../../bin -FU../../tmp -dUSE_SDL2 -dUSE_OPENGL -dUSE_OPENAL -dUSE_SDL2 -dUSE_XMP -dUSE_VORBIS -dUSE_OPUS -dUSE_GME Doom2DF.lpr
54 # Headless bin.
55 cd ../..
56 rm -R tmp
57 mkdir tmp
58 cd src/game
59 fpc -g -gl -FE../../bin -FU../../tmp -dUSE_SYSSTUB -dUSE_OPENAL -dUSE_XMP -dUSE_VORBIS -dUSE_MODPLUG -dUSE_OPUS -dUSE_GME -dUSE_HEADLESS -oDoom2DF_H Doom2DF.lpr
61 %install
63 # Create directories.
64 install -dm755 %{buildroot}/{usr/{bin,share/pixmaps}}
65 install -dm755 %{buildroot}/usr/share/doom2df
67 # Installing files.
68 # Game.
69 cd d2df-sdl/bin
70 install -D -m755 Doom2DF %{buildroot}%{_bindir}/Doom2DF
71 install -D -m755 Doom2DF_H %{buildroot}%{_bindir}/Doom2DF_H
73 # Other.
74 install -D -m644 %{SOURCE0} %{buildroot}/usr/share/pixmaps/doom2df.png
75 install -D -m644 %{SOURCE2} %{buildroot}/usr/share/applications/doom2df.desktop
76 install -D -m644 %{SOURCE4} %{buildroot}%{_mandir}/man1/d2df.1
78 %clean
79 rm -Rf d2df-sdl
80 rm -Rf %{buildroot}
82 %files
83 %defattr(0755,root,root)
85 # Binaries.
86 %{_bindir}/Doom2DF
87 %{_bindir}/Doom2DF_H
89 # Icons.
90 /usr/share/pixmaps/doom2df.png
92 # Desktop files.
93 /usr/share/applications/doom2df.desktop
95 # Man pages.
96 %{_mandir}/man1/d2df.1*